#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?[0-9]+([\,|\.][0-9]+)?$"
Local $sString = "1.0" & @CRLF & _
"1,0" & @CRLF & _
"100000,10000" & @CRLF & _
"+10.0" & @CRLF & _
"10" & @CRLF & _
"1" & @CRLF & _
"-10.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")