import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-+]?[0-9]+([\\,|\\.][0-9]+)?$";
final String string = "1.0\n"
+ "1,0\n"
+ "100000,10000\n"
+ "+10.0\n"
+ "10\n"
+ "1\n"
+ "-10.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}