re = /^[-+]?[0-9]+([\,|\.][0-9]+)?$/m
str = '1.0
1,0
100000,10000
+10.0
10
1
-10.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end