import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<.+?)\\s+style\\s*=\\s*([\"']).*?\\2(.*?>)";
final String string = "<p style=\"margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;\">Hello</p>";
final String subst = "\\1\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}