const regex = /[1-9]\d{0,4}\s+((optional|etc)\s+)?(\w+\s+){1,3}(suffix|end)\s+((optional|etc))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[1-9]\\d{0,4}\\s+((optional|etc)\\s+)?(\\w+\\s+){1,3}(suffix|end)\\s+((optional|etc))?', 'gm')
const str = `123 two unknown suffix optional`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}