// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[1-9]\d{0,4}\s+((optional|etc)\s+)?(\w+\s+){1,3}(suffix|end)\s+((optional|etc))?").unwrap();
let string = "123 two unknown suffix optional";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}