import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<ns3:[a-z,0-9]+>)\\{(fn:data(\\(\\$[a-z,0-9./,:]+\\)))\\}</ns3:[a-z,0-9]+>)";
final String string = "{\n"
+ " \"name\": \"Apostol\",\n"
+ " \"steam\": 76561198017242084\n"
+ " },";
final String subst = "{if($3)then$1else if($4)then$2else()}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}