using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\sNew User:\s(.+?_user)\sfunction:\s(auditor|auditor2)\s";
string input = @"blablabla bla bla blabla New User: John_user function: auditor blablablablabl bla blab New User: Do_user function: auditor2 blablabl blablb...";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}