using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ftp://.*\.mp3$";
string input = @"May 23 17:26:43 dnsonly webmin[2317]: Invalid login as root from 199.168.254.10";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}