$re = '/[2-6][1-8]-[2-6][1-8]/m';
$str = '23-65, 18-45, 21-68';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);