using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0414|0424|0412|0416|0426)[-][0-9]{7}$";
string substitution = @"^[04](1|2)(2|4|6)$";
string input = @"0426-1234567";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}