const regex = /((?:(?:PUBLIC|PRIVATE)[ \t]+)*(?:(?:DEFAULT)[ \t]+)*FUNCTION[ \t]+(?:(\w+)(?:[ \t]*\(([^\(\)]*)\))*))(?:.*)END FUNCTION/igms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?:PUBLIC|PRIVATE)[ \\t]+)*(?:(?:DEFAULT)[ \\t]+)*FUNCTION[ \\t]+(?:(\\w+)(?:[ \\t]*\\(([^\\(\\)]*)\\))*))(?:.*)END FUNCTION', 'igms')
const str = ` public default Function abc (a, b, c)
ksdjflkj lkjlk jd()
lkjdlkfj
lkdjf (sdfd())
kljlkj sd
fd fdsflkdsjjdsk lkjsdlkj
end Function`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}