package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(p\.?\s?[o|0]\.?\s?b\.?([o|0]x)?|post\soffice\sbox)`)
var str = `Pembroke St
Poembroke St
Portsea Boxhill
P O Box
P.O. Box
P O B O X
Pobox
PO BOX
P.O BOX
P0 B0X
Po 8ox
POST OFFICE Box 123
PO Box 123
Post Office st
po box
UNIT 210 2 PEMBROKE ST
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}