const regex = /(p\.?\s?[o|0]\.?\s?b\.?([o|0]x)?|post\soffice\sbox)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(p\\.?\\s?[o|0]\\.?\\s?b\\.?([o|0]x)?|post\\soffice\\sbox)', 'gi')
const str = `Pembroke St
Poembroke St
Portsea Boxhill
P O Box
P.O. Box
P O B O X
Pobox
PO BOX
P.O BOX
P0 B0X
Po 8ox
POST OFFICE Box 123
PO Box 123
Post Office st
po box
UNIT 210 2 PEMBROKE ST
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}