# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=[A-Za-z0-9][A-Za-z0-9@._%+-]{5,253}$)[A-Za-z0-9._%+-]{1,64}@(?:(?=[A-Za-z0-9-]{1,63}\.)[A-Za-z0-9]+(?:-[A-Za-z0-9]+)*\.){1,8}[A-Za-z]{2,63}$"
test_str = ("Format: minimum 2 characters @ minimum 3 characters . 2 - 63 characters\n\n"
"the g modifier let's us match multiple times in one string. the m modifier is useful here because it lets us treat each line as a seperate entry. Though in practice you probably dont need it for a simple one line email field\n\n"
"^(?=[A-Z0-9][A-Z0-9@._%+-]{5,253}+$)[A-Z0-9._%+-]{1,64}+@(?:(?=[A-Z0-9-]{1,63}+\\.)[A-Z0-9]++(?:-[A-Z0-9]++)*+\\.){1,8}+[A-Z]{2,63}+$\n\n"
"שדגכ@שדגכ\n\n"
"דגכ\n\n"
"אלפ@גכדץ.בםצ\n\n"
"Jim@stuff.co.uk\n\n"
"Jim@google.com\n\n"
"Henry@h.com\n\n"
"Joe @m.net\n\n"
"Joe@m.net\n\n"
"Joe@mo.net\n\n"
"Joe@sam.net\n\n"
"a@sam.net\n\n"
"mo@sam.org\n\n"
"12@sam.org\n\n"
"Jon@sam.c\n\n"
"Jon@sam.co\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.