import Foundation
let pattern = #"\b(i|em|b)(\w*)\/(i|em|b)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"{"query":"incessant","sourceLanguage":"en","targetLanguage":"en","primaries":[{"type":"headword","terms":[{"type":"text","text":"in·ces·sant","language":"en","labels":[{"text":"Adjective","title":"Part-of-speech"}]},{"type":"phonetic","text":"/inˈsesənt/","language":"und"},{"type":"sound","text":"http://www.gstatic.com/dictionary/static/sounds/de/0/incessant.mp3","language":"und"}],"entries":[{"type":"meaning","terms":[{"type":"text","text":"(of something regarded as unpleasant) Continuing without pause or interruption","language":"en"}],"entries":[{"type":"example","terms":[{"type":"text","text":"the emincessant/em beat of the music","language":"en"}]}]}]}]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)