$re = '/^(?:[A-Z]+\. ?)+$(?<! )/mi';
$str = 'Ing
Ing.
.Ing.
Xx Yy.
XX. YY.
XX.YY.
XX.YY. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);