#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!"Level\s\d+")(?<!")"?Level\s\d+"?"
Local $sString = "This is a test with various "Level 2" and Level 5 and stuff." & @CRLF & _
"" & @CRLF & _
"Not sure how to treat "Level 2 or Level 5" though." & @CRLF & _
"" & @CRLF & _
"Also capturing Level 12 would be nice I guess? (Not "Level 12" of course though)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")