const regex = /^(<[^<>]*>;\srel=\"(next|prev|last|first)\"(,\s)?)*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(<[^<>]*>;\\srel=\\"(next|prev|last|first)\\"(,\\s)?)*$', '')
const str = `<https://api.github.com/user/25254/followers?page=21>; rel="next", <https://api.github.com/user/25254/followers?page=332>; rel="last", <https://api.github.com/user/25254/followers?page=1>; rel="first", <https://api.github.com/user/25254/followers?page=19>; rel="prev"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}