use strict;
my $str = '<https://api.github.com/user/25254/followers?page=21>; rel="next", <https://api.github.com/user/25254/followers?page=332>; rel="last", <https://api.github.com/user/25254/followers?page=1>; rel="first", <https://api.github.com/user/25254/followers?page=19>; rel="prev"';
my $regex = qr/^(<[^<>]*>;\srel=\"(next|prev|last|first)\"(,\s)?)*$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}