#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[([^][]+)\](\(((?:[^()]+|(?2))+)\))"
Local $sString = "It's very easy to make some words **bold** and other words *italic* with Markdown. You can even [link to Google!](http://google.com)" & @CRLF & _
"[a link](https://www.wiki.com/atopic_(subtopic))" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")