using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^][]+)\](\(((?:[^()]+|(?2))+)\))";
string input = @"It's very easy to make some words **bold** and other words *italic* with Markdown. You can even [link to Google!](http://google.com)
[a link](https://www.wiki.com/atopic_(subtopic))
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}