package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^][]+)\](\(((?:[^()]+|(?2))+)\))`)
var str = `It's very easy to make some words **bold** and other words *italic* with Markdown. You can even [link to Google!](http://google.com)
[a link](https://www.wiki.com/atopic_(subtopic))
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}