Please enable JavaScript to use regex101
Regular
Expressions
101
Support Regex101
Social
Info
Regex Editor
Community Patterns
Account
Regex Quiz
Save & Manage Regex
Current Version:
1
Save & Share
Community Library
Editor
Flavor:
PCRE2 (PHP)
Match
Substitution
List
Unit Tests
Tools
Code Generator
Regex Debugger
Export Matches
Benchmark Regex
Format Regex
Sponsors
Explanation
An explanation of your regex will be automatically generated as you type.
Match Information
Detailed match information will be displayed here automatically.
Quick Reference
Search reference
All Tokens
Common Tokens
General Tokens
Anchors
Meta Sequences
Quantifiers
Group Constructs
Character Classes
Flags/Modifiers
Substitution
A single character of: a, b or c
[abc]
A character except: a, b or c
[^abc]
A character in the range: a-z
[a-z]
A character not in the range: a-z
[^a-z]
A character in the range: a-z or A-Z
[a-zA-Z]
Any single character
.
Alternate - match either a or b
a|b
Any whitespace character
\s
Any non-whitespace character
\S
Any digit
\d
Any non-digit
\D
Any word character
\w
Any non-word character
\W
Non-capturing group
(?:...)
Capturing group
(...)
Zero or one of a
a?
Zero or more of a
a*
One or more of a
a+
Exactly 3 of a
a{3}
3 or more of a
a{3,}
Between 3 and 6 of a
a{3,6}
Start of string
^
End of string
$
A word boundary
\b
Non-word boundary
\B
Regular Expression
Processing...
~
~
gm
Test String