package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)q[a-z]*`)
var str = `Eu quero
somente a primeira palavra que começa com "q"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}