using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__[A-Z0-9_]+__\(\s*(?:'[^'\\]*(?:\\.[^'\\]*)*'|\d+)(?:\s*,\s*(?:'[^'\\]*(?:\\.[^'\\]*)*'|\d+))*\s*\)";
string input = @"5 + __FXN1__('hello', 1, 3, '__HELLO__(\'hello\') + 5') + 5 + (2/2) + __FXN2__('Good boy')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}