const regex = /\b(?:[\w'-]{1,3}\W+[\w'-]{4,}|[\w'-]{4,}\W+[\w'-]{1,3}|[\w'-]{4,})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:[\\w\'-]{1,3}\\W+[\\w\'-]{4,}|[\\w\'-]{4,}\\W+[\\w\'-]{1,3}|[\\w\'-]{4,})\\b', 'g')
const str = `An elephant in the garden
history of elephants
Algebra A B-movies
Have you visted Calculus A?
I was in Calculus b
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}