import Foundation
let pattern = #"\bperformance_data>scratch_tapes=\K\d*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" <performance_data>scratch_tapes=6; total_tapes=38;</performance_data>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}