#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*[_].*)*(.*)"
Local $sString = "test_my_ass_hour_123123123313213"
Local $sSubst = "Test My Ass Hour 123123123313213"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)