using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*[_].*)*(.*)";
string substitution = @"Test My Ass Hour 123123123313213";
string input = @"test_my_ass_hour_123123123313213";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}