// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*[_].*)*(.*)").unwrap();
let string = "test_my_ass_hour_123123123313213";
let substitution = "Test My Ass Hour 123123123313213";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}