import Foundation
let pattern = #"(.*[_].*)*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test_my_ass_hour_123123123313213"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Test My Ass Hour 123123123313213"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)