const regex = /!(?!(.|\n|\r)*FastEthernet\d\d?\/\d\d?\.\d{1,3})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('!(?!(.|\\n|\\r)*FastEthernet\\d\\d?\\\/\\d\\d?\\.\\d{1,3})', '')
const str = `interface FastEthernet0/0
shutdown
!
interface FastEthernet0/0.100
ip address 192.168.1.100
!
interface FastEthernet0/1
shutdown
!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}