// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(grouping\()(?:\([^()]*\)|[^()])*\)").unwrap();
let string = "grouping(elllo)
grouping(function() {
console.log(\"hello\")
})";
let substitution = "\\1foo)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}