$re = '/\/\*(?!(\<\!\[CDATA\[)|(\]\]>))(.*?)\*\//s';
$str = '<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/lib.js?<?php echo CACHEBUST; ?>"></script>
<?php /*<script type="text/javascript" src="//<?php echo SITE_CDN_STATIC_DOMAIN; ?>/src/js/prod.js.php?<?php echo CACHEBUST; ?>"></script> */ ?>
<script type="text/javascript">
/*<![CDATA[*/
updateBodyClassContext();
cookieSetContext();
/* Run code on page load */
addEvent(window, \'load\', function()
{
/**
*
* Example comment inside of
* CDATA
*
*/
document.getElementById(\'emailm\').focus();
if (location.href.indexOf(\'prereg=2\') > -1) document.getElementById(\'prereg_email\').focus();
addEvent(document.getElementById(\'prereg_form\'), \'submit\', function(e)
{
var e = (e) ? e : window.event,
regex_email = /^([a-z0-9])(([-a-z0-9._])*([a-z0-9_-]))*@([a-z0-9])(([a-z0-9-])*([a-z0-9]))+(\\.([a-z0-9])([-a-z0-9-])?([a-z0-9])+)+$/i;
if (this.prereg_email.value == \'\'
|| !regex_email.test(this.prereg_email.value))
{
this.prereg_email.focus();
stopEvent(e);
}
});
});
/*]]>*/
</script>
/* another comment for good measure */
/*and another
*/
/*another*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);