package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<(?:button|input|a)\s+[^>]*class\s*=\s*["'][^"']*btn[^"']*[^>]*>`)
var str = `<button type="submit" class="btn btn-default btn-block">
<input type="button" class="btn btn-default multilingual-helper" value="{{ language.code.upper() }}"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}