#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^.*(?=\d{2,3}\sms\b)"
Local $sString = "2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")