use strict;
my $str = '2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf';
my $regex = qr/^.*(?=\d{2,3}\sms\b)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}