import re
regex = re.compile(r"^.*(?=\d{2,3}\sms\b)")
test_str = "2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")