$re = '/Bob[\s._-]1[\s._-]/i';
$str = 'Hello, I\'m Bob 1
Hello, I\'m Bob 11
Hey, it\'s Bob-1 over there
Hey, it\'s Bob - 1 over there
Bob.1
Bob_1 rules!
Bob1
Bob 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);