use strict;
my $str = '[text](link) ![image][link][text](link)
 [text](link)';
my $regex = qr/(?|(!\[[^][]+]\([^()]+\))(\[[^][]+]\([^()]+\))|(!\[[^][]+]\[[^][]+])(\[[^][]+]\([^()]+\)))/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";