#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*"(?:IpAddress":"\K[0-9]{1,3}(?:\.[0-9]{1,3}){3}|WorkstationName":"\K[^"]*)(?=")"
Local $sString = "# IPADDR = 192.10.10.10" & @CRLF & _
"... "WorkstationName":"WS-8300E-007","IpAddress":"192.10.10.10" ..." & @CRLF & _
"" & @CRLF & _
"# IPADDR = WS-8300E-007" & @CRLF & _
"... "WorkstationName":"WS-8300E-007","IpAddress":"-" ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")