$re = '/^.*"(?:IpAddress":"\K[0-9]{1,3}(?:\.[0-9]{1,3}){3}|WorkstationName":"\K[^"]*)(?=")/m';
$str = '# IPADDR = 192.10.10.10
... "WorkstationName":"WS-8300E-007","IpAddress":"192.10.10.10" ...
# IPADDR = WS-8300E-007
... "WorkstationName":"WS-8300E-007","IpAddress":"-" ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);