use strict;
my $str = 'x
xx
xxxx
xxxxxxxx
xxxxxxxxxxxxxxxx
xx…(32)…xx
xx…(64)…xx
xx…(128)…xx
xx…(256)…xx
xx…(512)…xx
xx…(1024)…xx';
my $regex = qr/^(?!(.(..)+)\1*$)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}