$re = '/
/';
$str = 'http://www.bollywoodhungama.com/more/photos/view/stills/celebrity-photos/id/20474273';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);