# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?)(\s[A-Za-z]|[;:])/\1/mg;t' <<< "Hello a
Hello !world I
Welcome; to"