use strict;
my $str = 'Hello a
Hello !world I
Welcome; to';
my $regex = qr/^(.*?)(\s[A-Za-z]|[;:])/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";