re = /^(.*?)(\s[A-Za-z]|[;:])/m
str = 'Hello a
Hello !world I
Welcome; to'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result