#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<line>[^\)]+\)\n\N+)"
Local $sString = "Content-Transfer-Encoding: 7bit" & @CRLF & _
" Scheduled job console-context --evs 1 quota list --verbose FIRST_FS produced the following output:" & @CRLF & _
" Type : Explicit" & @CRLF & _
" Target : ViVol: VOL_ABC" & @CRLF & _
" Usage : 100 GB" & @CRLF & _
" Limit : 500 GB (Hard)" & @CRLF & _
" Last modified : 2010-12-19 04:56:50.834383000+00:00" & @CRLF & _
" Type : Explicit" & @CRLF & _
" Target : ViVol: VOL_XYZ" & @CRLF & _
" Usage : 609 GB" & @CRLF & _
" Limit : 3 TB (Hard)" & @CRLF & _
" Last modified : 2010-12-21 04:04:23.757073000+00:00" & @CRLF & _
" Type : Explicit" & @CRLF & _
" Target : ViVol: VOL_123" & @CRLF & _
" Usage : 609 GB" & @CRLF & _
" Limit : 3 TB (Hard)" & @CRLF & _
" Last modified : 2010-12-21 04:04:23.757073000+00:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")