package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<line>[^\)]+\)\n\N+)`)
var str = `Content-Transfer-Encoding: 7bit
Scheduled job console-context --evs 1 quota list --verbose FIRST_FS produced the following output:
Type : Explicit
Target : ViVol: VOL_ABC
Usage : 100 GB
Limit : 500 GB (Hard)
Last modified : 2010-12-19 04:56:50.834383000+00:00
Type : Explicit
Target : ViVol: VOL_XYZ
Usage : 609 GB
Limit : 3 TB (Hard)
Last modified : 2010-12-21 04:04:23.757073000+00:00
Type : Explicit
Target : ViVol: VOL_123
Usage : 609 GB
Limit : 3 TB (Hard)
Last modified : 2010-12-21 04:04:23.757073000+00:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}